Nuxtのcore-jsエラーの解決方法 備忘録

最終更新日:2020年2月15日 Nuxt

Nuxtでプロジェクトを作成した後、npm run devにて開発モードでプロジェクトを実行しようとしたら、以下のようにcore-jsのエラーが発生したので、解決方法を備忘録に残す。

先人によると、この問題は、core-jsを3系から2系にダウングレードすることで解決するようだ。

そこで、npm install core-js@2.6.11をインストールすることにした。

そして、npm run devで再度開発サーバーを立ち上げる。

今度はうまくコンパイルされて実行された。

以下ページにアクセスすると、正しく表示されている。

http://localhost:3000/

なお、上記のエラーは、公式ページによると以下の手順で解消できるという。

 

  1. package-lock.json ファイルを削除します
  2. node_modules ディレクトリを削除します
  3. npm install コマンドを実行します
  4. インストールが完了し、テストを実行した後は、他の依存関係のアップグレードも検討してください。npm outdated コマンドが使用できます。

出典:https://ja.nuxtjs.org/guide/upgrading

 

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です